Register
It is currently Sat Dec 20, 2014 4:39 am

Display issues for dialog cmd when executed from rc.local.


All times are UTC - 6 hours


Post new topic Reply to topic  [ 2 posts ] 
Author Message
 PostPosted: Mon Jul 06, 2009 10:34 am   

Joined: Mon Jul 06, 2009 9:30 am
Posts: 8
Hello,

I have a simple script that display a form. It looks perfect when executed 'manually'. However, when the exact same script is executed by rc.local, it is not displayed correctly.

See link here for screen shots: http://api.virtualcad.com/misc/display.jpg

What I have learned so far, is that the terminal/environment is not the same when a program is executed by rc.local and that I may need to execute my script using a 'pseudo-tty wrapper'. However, I can't find any answers - perhaps I am not using the right keywords, but Google isn't helping. :(

Can someone steer me in the right direction?

Thanks,

Eric


Top
 Profile  
 PostPosted: Mon Jul 06, 2009 7:51 pm   

Joined: Mon Jul 06, 2009 9:30 am
Posts: 8
Everyone,

Sorry - new to this forum and I should have posted this in the Programming section - so I moved it there.

Thanks,

Eric


Top
 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  


BashScripts | Promote Your Page Too
Powered by phpBB © 2011 phpBB Group
© 2003 - 2011 USA LINUX USERS GROUP